PAT 1132 Cut Integer [string相关操作] [余数为0的浮点错误]

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

--------------------------------------这是题目和解题的分割线--------------------------------------

想要快速将数字切成两半,那自然得是字符串上场啦~这里用到几个string相关操作,简单说一下。

.substr(n,x) 截取字符串

获得从第n个位置开始的长度为x的字符串

比如,string s = "12345",s.substr(2,3) = “345"

② stoi(str) 字符转整型

没什么好介绍的,不过这是C++11中的函数,有的编译器得设置一下,不然会报错。

最后是浮点错误的原因,余数和除数一样是不能为0的,必须加一个判断~

#include<iostream>
#include<string>

using namespace std;

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		string str,a,b;
		cin>>str;
		//对半切 
		a = str.substr(0,str.length()/2);
		b = str.substr(str.length()/2);
		//注意!余数不为0! 
		if(stoi(a)*stoi(b)!=0&&stoi(str)%(stoi(a)*stoi(b))==0)
			cout<<"Yes\n";
		else
			cout<<"No\n";
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值