1132 Cut Integer (20分) (浮点错误分析)

1132 Cut Integer (20分)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2 ^31​​ ). It is guaranteed that the number of digits of Z is an even number.

Output Specification:
For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

本题思路:用string读入数据,然后利用substr取左右两子串,将字符串转换为整数,如果能够整除ab则符合条件(浮点错误原因:存在ab等于0的情况,因此需要额外做判断)

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int n,p,q,a;
int change(string l)
{
    int ans=0;
    for(int i=0;i<l.size();i++)
        ans=ans*10+l[i]-'0';
    return ans;
}

int main()
{
    cin >> n;
    string m,l,r;
    for(int i=0;i<n;i++)
    {
        if(i!=0)
            printf("\n");
        cin >> m;
        l=m.substr(0,m.size()/2);
        r=m.substr(m.size()/2,m.size()/2);
        a=change(m);
        p=change(l);
        q=change(r);
        if((p*q)!=0&&a%(p*q)==0)
            printf("Yes");
        else
            printf("No");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值