平衡树模板&&bzoj 3223&&Tyvj 1729 文艺平衡树

5 篇文章 0 订阅
3 篇文章 0 订阅

Time Limit: 10 Sec Memory Limit: 128 MB
您需要写一种数据结构(可参考题目标题),来维护一个有序数列,其中需要提供以下操作:翻转一个区间,例如原有序序列是5 4 3 2 1,翻转区间是[2,4]的话,结果是5 2 3 4 1
Input
第一行为n,m n表示初始序列有n个数,这个序列依次是(1,2……n-1,n) m表示翻转操作次数
接下来m行每行两个数[l,r] 数据保证 1<=l<=r<=n
Output
输出一行n个数字,表示原始序列经过m次变换后的结果

Sample Input
5 3
1 3
1 3
1 4

Sample Output

4 3 2 1 5

HINT

N,M<=100000

平衡树的基础运用。在翻转区间[l,r]时先将节点l-1,r+1分别转到head,head->ch[1],此时将标记打在head->ch[1]->ch[0]上即可。
注意在伸展时将伸张路径上的点都进行一次标记的下传,以及在统计点数和寻找节点时都要注意标记的下传。
具体下传方式就是如果该节点有标记,则将其左右子树交换位置,并使其子树的标记异或1。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#define N 100010
using namespace std;
struct node { int num,mark,f,size;node *ch[2],*fa;node() { num=f=mark=size=0;fa=ch[0]=ch[1]=NULL; } }s[N];
node *null,*head;int n,m,l,r;
struct memory {
    int tot;memory() { tot=0; }
    node *out(int n,int f,node *fa) { node *p=s+tot++;p->num=n,p->f=f,p->fa=fa;return p; }
}pool;
void mark_down(node *now) {
    if(now==NULL) return;
    if(now->mark) {
      swap(now->ch[0],now->ch[1]); now->mark=0;
      if(now->ch[0]!=NULL) now->ch[0]->mark^=1,now->ch[0]->f^=1;
      if(now->ch[1]!=NULL) now->ch[1]->mark^=1,now->ch[1]->f^=1;
    }
    return;
}
void count(node *now) {
    if(now==NULL) return;
    int t=1;
    if(now->ch[0]!=NULL) t+=now->ch[0]->size;
    if(now->ch[1]!=NULL) t+=now->ch[1]->size;
    now->size=t; return;
}
void check(node *now,node *to) {
    node *tr[N];int tot=0;
    while(now!=to) { tr[++tot]=now;now=now->fa; }
    while(tot>0) { mark_down(tr[tot--]); }
}
void rorate(node *now) { 
    node *fa=now->fa;int d=now->f;
    if(now->ch[d^1]!=NULL) now->ch[d^1]->fa=fa,now->ch[d^1]->f=d;fa->ch[d]=now->ch[d^1];
    now->fa=fa->fa;fa->fa->ch[fa->f]=now;now->f=fa->f;fa->f=d^1;
    now->ch[d^1]=fa;fa->fa=now;
    count(fa);count(now); return;
}
void splay(node *now,node *to) {
    if(now==NULL) return;
    check(now,to); while(now->fa!=to) {
      if(now->fa->fa==to) { rorate(now); break; }
      else if(now->f==now->fa->f) rorate(now->fa),rorate(now);
      else rorate(now),rorate(now);
    }if(to==null) head=now;
}
void build(int sum) {
    null=pool.out(0,0,null),head=pool.out(0,0,null);
    sum+=2;head->size=sum; node *now=head;int t=1;sum--;
    while(sum--) {
      now->ch[1]=pool.out(t++,1,now);now=now->ch[1];now->size=n+1;
      if(rand()%2) splay(now,null);
    } return;
}
node *find(node *now,int t,node *to) {
    while(now!=NULL) {
      mark_down(now);int ti;
      if(now->ch[0]==NULL) ti=1;
      else ti=now->ch[0]->size+1;
      if(ti==t) { splay(now,to);return now; }
      else if(ti>t) now=now->ch[0];
      else t-=ti,now=now->ch[1];
    }
}
void rev(int l,int r) {
    if(l>r) swap(l,r);
    node *left=find(head,l,null),*right=find(head,r,head);
    node *now=head->ch[1]->ch[0];
    if(now==NULL) return;else now->mark=now->mark^1;
}
void print(node *now) {
    if(now==NULL) return;mark_down(now);
    print(now->ch[0]);
    if(now->num!=0&&now->num<=n) printf("%d ",now->num);
    print(now->ch[1]);
}
int main() {
    scanf("%d%d",&n,&m);build(n);
    for(int i=1;i<=m;i++)  scanf("%d%d",&l,&r),rev(l,r+2);
    print(head);return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值