hdu 2222 Keywords Search (AC自动机)

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 71488    Accepted Submission(s): 24396


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

Author
Wiskey
 

Recommend
lcy

题意:

给出了N个子串问在主串中能匹配多少个子串。子串不能重复出现在主串中。

思路:

用AC自动机,cnt记录下到达该节点的完整的子串的个数。然后用失配指针找到所有的可以匹配到的,在计算了以这个结点为结束的子串后要把cnt赋值为-1,防止它再次计算。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int maxn=1000005;
char str[maxn];
struct node
{
    node *next[26];
    node *fail;
    int cnt;
    node()
    {
        memset(next,NULL,sizeof(next));
        fail=NULL;
        cnt=0;
    }
};
queue<node *> que;
void in(node *root,char str[])
{
    node *now=root;
    int i=0;
    while(str[i])
    {
        int x=str[i]-'a';
        if(now->next[x]==NULL)
        {
            now->next[x]=new node();
        }
        now=now->next[x];
        i++;
    }
    now->cnt++;
}
void makefail(node *root)
{
    root->fail=NULL;
    que.push(root);
    while(!que.empty())
    {
        node *now=que.front();
        que.pop();
        node *p=NULL;
        for(int i=0;i<26;i++)
        {
            if(now->next[i]!=NULL)
            {
                if(now==root) now->next[i]->fail=root;
                else
                {
                    p=now->fail;
                    while(p!=NULL)
                    {
                        if(p->next[i]!=NULL)
                        {
                            now->next[i]->fail=p->next[i];
                            break;
                        }
                        p=p->fail;
                    }
                    if(p==NULL) now->next[i]->fail=root;
                }
                que.push(now->next[i]);
            }
        }
    }
}
int query(node *root,char str[])
{
    node* now=root;
    int ans=0;
    int len=strlen(str);
    for(int i=0;i<len;i++)
    {
        int x=str[i]-'a';
        while(now->next[x]==NULL&&now!=root) now=now->fail;
        now=now->next[x];
        if(now==NULL)
            now=root;
        node* tmp=now;
        while(tmp!=NULL&&tmp->cnt!=-1)
        {
            ans+=tmp->cnt;
            tmp->cnt=-1;
            tmp=tmp->fail;
        }
    }
    return ans;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        node *root=new node();
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%s",str);
            in(root,str);
        }
        makefail(root);
        scanf("%s",str);
        printf("%d\n",query(root,str));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值