SDNU 1116.Keywords Search AC自动机 裸题

1116.Keywords Search

Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system. Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.


Input
First line will contain an integer N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.


Output

Print how many keywords are contained in the description.


Sample Input
5
she
he
say
shr
her

yasherhs


Sample Output

3


    一道AC自动机的裸题,题意是说输入一个n,然后输入n个字符串,最后再输入一个字符串,问这个字符串包含前面的几个字符串,这类问题的解决就是用AC自动机来解决。AC自动机其实就是先构建一棵字典树,然后用KMP算法来查找匹配,具体的就不细说了,给个链接http://blog.csdn.net/liu940204/article/details/51347064

    下面AC代码:(因为不想用指针所以用的kuangbin板子,没用前面链接里那个板子...)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct Trie
{
    int next[500005][26],fail[500005],en[500005];
    int root,L;
    int newnode()
    {
        int i;
        for(i=0;i<26;i++)
        {
            next[L][i]=-1;
        }
        en[L++]=0;
        return L-1;
    }
    void init()
    {
        L=0;
        root=newnode();
    }
    void inser(char buf[])
    {
        int i;
        int len=strlen(buf);
        int now=root;
        for(i=0;i<len;i++)
        {
            if(next[now][buf[i]-'a']==-1)
                next[now][buf[i]-'a']=newnode();
            now=next[now][buf[i]-'a'];
        }
        en[now]++;
    }
    void build()
    {
        int i;
        queue<int>Q;
        fail[root]=root;
        for(i=0;i<26;i++)
        {
            if(next[root][i]==-1)
                next[root][i]=root;
            else
            {
                fail[next[root][i]]=root;
                Q.push(next[root][i]);
            }
        }
        while(!Q.empty())
        {
            int i;
            int now=Q.front();
            Q.pop();
            for(i=0;i<26;i++)
            {
                if(next[now][i]==-1)
                    next[now][i]=next[fail[now]][i];
                else
                {
                    fail[next[now][i]]=next[fail[now]][i];
                    Q.push(next[now][i]);
                }
            }
        }
    }
    int query(char buf[])
    {
        int len=strlen(buf);
        int now=root;
        int res=0;
        int i;
        for(i=0;i<len;i++)
        {
            now=next[now][buf[i]-'a'];
            int temp=now;
            while(temp!=root)
            {
                res+=en[temp];
                en[temp]=0;
                temp=fail[temp];
            }
        }
        return res;
    }
    /*void debug()
    {
        int i,j;
        for(i=0;i<L;i++)
        {
            cout<<"id = "<<i<<" fail = "<<fail[i]<<"en = "<<en[i]<<endl;
            cout<<"chi = ";
            for(j=0;j<26;j++)
            {
                cout<<next[i][j];
            }
            cout<<endl;
        }
    }*/
};

char s[1000005];
Trie ac;

int main()
{
    int n;
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        ac.init();
        for(i=0;i<n;i++)
        {
            scanf("%s",s);
            ac.inser(s);
        }
        ac.build();
        scanf("%s",s);
        cout<<ac.query(s)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值