OJ第三批——Problem I:投简历

问题及代码:

Problem I: 投简历

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 722   Solved: 509
[ Submit][ Status][ Web Board]

Description

小华历经12寒窗苦读,又经历4年大学磨砺,终于毕业了,随着毕业季的到来,找工作也日益紧张起来。由于要面试不同的公司,因此小华需要准备不同的简历。当然最基本的信息是必不可少的,基本信息:姓名、年龄、性别、专业。现有两家公司,小华想要投简历试一试。第一家langchao公司需要了解小华毕业学校,第二家lenovo公司需要了解小华的薪金目标(pay)。
请你用类中继承的方法帮助他完成简历吧*-*  *-*  *-*

Input

输入两行,第一行:小华的信息。第二行:小华想要进入的公司名称。

Output

小华要递交的简历内容

Sample Input

xiaohua 25 F IT YT 8000
langchao

Sample Output

name:xiaohua
age:25
sex:F
major:IT
school:YT

HINT

前置代码及类型定义已给定如下,提交时不需要包含,会自动添加到程序前部


#include <iostream>

#include <string>

using namespace std;

class jianli

{

public:

    void getvalue(){

        cin>>name>>age>>sex>>major;

    }

    void display();

private:

    string name;

    int age;

    char sex;

    string major;

};


主函数已给定如下,提交时不需要包含,会自动添加到程序尾部







/* C++代码 */


int main()

{

    jianli1 xiaohua;

    jianli2 xiaohua2;

    string a="langchao",b="lenovo";

    string c;

    xiaohua.getvalue();

    xiaohua.getvalue1();

    xiaohua2.getvalue2();

    cin>>c;

    if(c==a){

        xiaohua.display();

        xiaohua.display1();

    }

    if(c==b){

        xiaohua.display();

        xiaohua2.display2();

    }

    return 0;

}

 

#include <iostream>
#include <string>

using namespace std;
class jianli
{
public:
    void getvalue()
    {
        cin>>name>>age>>sex>>major;
    }
    void display();
private:
    string name;
    int age;
    char sex;
    string major;
};

class jianli1
{
public:
    void getvalue()
    {
        cin>>name>>age>>sex>>major;
    }
    void getvalue1()
    {
        cin>>school;
    }
    void display()
    {
        cout<<"name:"<<name<<endl;
        cout<<"age:"<<age<<endl;
        cout<<"sex:"<<sex<<endl;
        cout<<"major:"<<major<<endl;
    }
    void display1()
    {
        cout<<"school:"<<school<<endl;
    }
private:
    string name;
    int age;
    char sex;
    string major;
    string school;
};

class jianli2
{
public:
    void getvalue2()
    {
        cin>>pay;
    }
    void display2()
    {
        cout<<"pay:"<<pay<<endl;
    }
private:
    int pay;
};

int main()
{
    jianli1 xiaohua;
    jianli2 xiaohua2;
    string a="langchao",b="lenovo";
    string c;
    xiaohua.getvalue();
    xiaohua.getvalue1();
    xiaohua2.getvalue2();
    cin>>c;
    if(c==a)
    {
        xiaohua.display();
        xiaohua.display1();
    }
    if(c==b)
    {
        xiaohua.display();
        xiaohua2.display2();
    }
    return 0;
}


 

 

运行结果:

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值