The Cow Lexicon(DP)

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a’…‘z’. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said “browndcodw”. As it turns out, the intended message was “browncow” and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a’…‘z’) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input
Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3…W+2: The cows’ dictionary, one word per line
Output
Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
Sample Input
6 10
browndcodw
cow
milk
white
black
brown
farmer
Sample Output
2
Sponsor

dp[i]=min(dp[i],dp[pm]+(pm-i)-len);

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int w,l;
char ch[610];
string vec[610];
int f[610];
int main()
{
	cin>>w>>l;
	for(int i=0;i<l;i++) cin>>ch[i];
	for(int i=0;i<w;i++) cin>>vec[i];
	f[l]=0;
	for(int i=l-1;i>=0;i--)//从后向前更新
	{
		f[i]=f[i+1]+1;//当前字符需要删除 
		for(int j=0;j<w;j++)//遍历每个词 
		{
			int len=vec[j].length();//长度
			if(len<=l-i+1&&vec[j][0]==ch[i])
//当前遍历到的字符串中的字符到字符串尾的长度大于等于查询单词的长度
//当前遍历到的字符串中的字符等于该单词的首字母
			{
				int pm=i;//ch的指针 
				int pz=0;//vec的指针
				while(pm<l)//检索从此向后是否逐字匹配
				{
					if(vec[j][pz]==ch[pm++])
					{
						pz++;
					}
					if(pz==len)
					{
						f[i]=min(f[i],f[pm]+(pm-i)-len);
					//所完成从i向后到l与该单词逐字匹配所以更新维护f[]
						break;
					}
				}
			}
		}
	}
	cout<<f[0];
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值