如题:http://poj.org/problem?id=2376
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12069 | Accepted: 3140 |
Description
Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.
Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
Sample Input
3 10 1 7 3 6 6 10
Sample Output
2
Hint
INPUT DETAILS:
There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.
OUTPUT DETAILS:
By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.
Source
要求每一个牛可以覆盖一个区间,求出最少的牛覆盖1-T的区间。
特别注意:已覆盖区间的右端点是闭的,比如一头牛干到t=3,下一头牛可以从4开始干。WA了我半天 幸好discuss里有一组数据,不然我还以为要完全覆盖所有区间...
粗心大意怎么治..愁人
贪心思路:设当前已经覆盖的区间右端点now_pos,每次选择一头牛,满足左端小于now_pos,右端尽可能大...
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node
{
int l,r;
};
node a[25005];
int N,T;
int now_pos=0;
int cmp(node &a,node &b)
{
if(a.l!=b.l)
return a.l<b.l;
else
return a.r<b.r;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
scanf("%d%d",&N,&T);
int i;
for(i=0;i<N;i++)
scanf("%d%d",&a[i].l,&a[i].r);
sort(a,a+N,cmp);
i=0;
int res=0;
while(now_pos<T&&i<N)
{
if(a[i].l>now_pos+1)
{
printf("-1\n");
return 0;
}
int max=0;
while(i<N&&a[i].l<=now_pos+1)
{
if(a[i].r-now_pos>max)
{
max=a[i].r-now_pos;
}
i++;
}
if(max!=0)
{
now_pos+=max;
res++;
}
}
if(now_pos>=T)
{
printf("%d\n",res);
}
else
printf("-1\n");
return 0;
}