poj3616 dp

31 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=3616

Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5228 Accepted: 2162

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

 

 

题目大意:给树M个时间段,和挤奶量,每个时间段牛都可以挤出给定量的奶,挤完一次奶,要休息R时间,求N时间前最多能挤多少奶。

注意:奶牛挤奶时间区间是开区间。(starting_houri < ending_houriN)

 

思路:设dp[i]表示奶牛i的结束时间前最多的奶量。

           dp[i]=max(dp[i],dp[j]+a[i].weight)   其中0<=j<i&&a[i].start>=a[j].end+R.

           i   [1~M]

           j    [0~i)

  

    

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define max(a,b)(a>b?a:b)

struct node
{
 int start,end,weight;
};
node a[1050];
int dp[1000005];

int cmp(node &a,node &b)
{
 return a.start<b.start;
}

int main()
{
 int N,M,R;
// freopen("C:\\1.txt","r",stdin);
 scanf("%d%d%d",&N,&M,&R);
 int i,j;
 for(i=1;i<=M;i++)
  scanf("%d%d%d",&a[i].start,&a[i].end,&a[i].weight);
 sort(a+1,a+1+M,cmp);
 int res=-0x0fffffff;
 for(i=1;i<=M;i++)
  dp[i]=a[i].weight;
 for(i=1;i<=M;i++)
  for(j=0;j<i;j++)
   if(a[i].start>=a[j].end+R)
   {
    dp[i]=max(dp[i],dp[j]+a[i].weight);
    if(res<dp[i])
    res=dp[i];
   }
 printf("%d\n",res);
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值