poj2395 最小生成树

 

如题:http://poj.org/problem?id=2395

Out of Hay
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11734 Accepted: 4598

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

Source

 

题目大意:给出顶点数N和边数M,然后给出M条边,求最小生成树的最大边权。

 

思路:最顺手的kruskal,一般的最小生成树一定要考虑

1.重边

2.图的连通性

这一题不必担心连通性,Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

因为是kruskal,不必担心重边,因为拍完序,从小的取,后面的重边也取不到了

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define max(a,b)(a>b?a:b)
struct node
{
 int from,to,cost;
};
node edg[10005];

int cmp(node &a,node &b)
{
 return a.cost<b.cost;
}
int f[2005];
void init_set()
{
 int i;
 for(i=0;i<1005;i++)
  f[i]=i;
}

int find(int x)
{
 if(x==f[x])
  return f[x];
 return f[x]=find(f[x]);
}
int same(int x,int y)
{
 if(find(x)==find(y))
  return 1;
 return 0;
}
void Unite(int x,int y)
{
 int fx=find(x);
 int fy=find(y);
 if(fx!=fy)
  f[fx]=fy;
}


int main()
{
 freopen("C:\\1.txt","r",stdin);
 int N,M;
 cin>>N>>M;
 int i,cnt=0;
 for(i=1;i<=M;i++)
 {
  int a,b,c;
  scanf("%d%d%d",&a,&b,&c);
  edg[cnt].from=a;
  edg[cnt].to=b;
  edg[cnt].cost=c;
  cnt++;
 }
 sort(edg,edg+cnt,cmp);
 init_set();
 int res=-0x0fffffff;
 for(i=0;i<cnt;i++)
 {
  if(!same(edg[i].from,edg[i].to))
  {
   Unite(edg[i].from,edg[i].to);
   res=max(res,edg[i].cost);
  }
 }
 cout<<res<<endl;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值