如题:http://poj.org/problem?id=2377
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 11056 | Accepted: 4661 |
Description
Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input
* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
Sample Input
5 8 1 2 3 1 3 7 2 3 10 2 4 4 2 5 8 3 4 6 3 5 2 4 5 17
Sample Output
42
Hint
The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
Source
题目大意:求最大生成树。
思路:kruskal。重边排序后不必担心,连通性需要判断,不连通输出-1
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
int from,to,cost;
};
node edg[20005];
int cmp(node &a,node &b)
{
return a.cost>b.cost;
}
int f[1005];
void init_set()
{
int i;
for(i=0;i<1005;i++)
f[i]=i;
}
int find(int x)
{
if(x==f[x])
return f[x];
return f[x]=find(f[x]);
}
int same(int x,int y)
{
if(find(x)==find(y))
return 1;
return 0;
}
void Unite(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
f[fx]=fy;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
int N,M;
cin>>N>>M;
int i,cnt=0;
for(i=1;i<=M;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
edg[cnt].from=a;
edg[cnt].to=b;
edg[cnt].cost=c;
cnt++;
}
init_set();
sort(edg,edg+cnt,cmp);
int res=0;
int num=0;
for(i=0;i<cnt;i++)
{
if(!same(edg[i].from,edg[i].to))
{
num++;
Unite(edg[i].from,edg[i].to);
res+=edg[i].cost;
}
}
if(num!=N-1)
cout<<-1<<endl;
else
cout<<res<<endl;
}