poj3276 翻转

27 篇文章 0 订阅

 

如题:http://poj.org/problem?id=3276

Face The Right Way
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2858 Accepted: 1317

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ KN) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N
Lines 2.. N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source

 

 

题目大意:有K头牛排成一排,F代表头朝前,B代表头朝后,最终需要让他们全部头朝前,输出最小的翻转次数M和每次翻转K头牛。

 

思路:很好的一道题。每次翻转的区间的范围k∈【1,N】,然后对于每一个k,求出最小的翻转次数。

如何判断当前第i头牛是否需要翻转。从第i头牛开始翻,翻的区间是[i,i+k-1]。设f【i】代表区间[i,i+k-1]是否翻转了。

如果前面全都翻转好了,那么这时第i的头是向后,就翻转这个区间。

如何判断前面翻转过后i的头是向哪里的?

想一下就知道,可以影响到第i头牛的翻转只可能是[i-k+1,i-1],因为每次翻转的区间长度是k,这里面任意一头牛翻转,后面的区间全部翻转,如果[i-k+1,i-1]一共翻转的是奇数次,那么i的方向和原来相反,在看下原来i的方向即可知道是否翻转当前[i,i+k-1]区间.或if(a[i]+cnt)%2)就需要翻转,可以自己推一下。a数组是原始的方向。F:0,B:1.

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int N;
int a[5005];
int f[5005]; //区间[i,i+k-1]是否进行了翻转


int solve(int k)
{
 memset(f,0,sizeof(f));
 int i;
 int cnt=0;
 int res=0;
 for(i=0;i+k-1<N;i++)
 {
  if((a[i]+cnt)%2)
  {
   res++;
   f[i]=1;
  }
  cnt+=f[i];
  if(i-k+1>=0)
   cnt-=f[i-k+1];
 }
 for(i=N-k+1;i<N;i++)
 {
  if((a[i]+cnt)%2)
   return -1;
  if(i-k+1>=0)
   cnt-=f[i-k+1];
 }
 return res;
}
int main()
{
 cin>>N;
 int i;
 getchar();
 for(i=0;i<N;i++)
 {
  char ch;
  scanf("%c",&ch);
  if(ch=='F')
   a[i]=0;
  else
   a[i]=1;
  getchar();
 }
 int K,k,m,M=0x0fffffff;
 for(k=1;k<=N;k++)
 {
  m=solve(k);
  if(m>=0&&M>m)
  {
   K=k;
   M=m;
  }
 }
 cout<<K<<" "<<M<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值