poj1013 模拟

27 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=1013

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41224 Accepted: 13142

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

Source

 

 

 

思路:注意最后一句话The solution will always be uniquely determined.

我们很难去找出唯一一个不知道轻还是重的那个假钱,但是因为答案是唯一的,所以我们可以利用3次称重,确定出所有的真钱。

如果是even,代表两边的钱全是真的。

如果是up或down,代表两边没出现的钱全是真的。

我们还可以发现,如果在一次称重中,一个钱被认为是重,如果下面的称量,它就不可能称出轻,如果称出来了,代表它一定是真钱。轻也一样,下面如果称出重就是真钱。

开3个数组,int True[15]={0},heavy[15]={0},light[15]={0};记录真钱和它是重还是轻,矛盾的时候加入真钱的数组。

因为只有一个假钱,最终遍历一边真钱数组,肯定能找到假的。

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
// freopen("C:\\1.txt","r",stdin);
 int T;
 cin>>T;
 while(T--)
 {
  int True[15]={0},heavy[15]={0},light[15]={0};
      int i,j;
  for(i=0;i<3;i++)
  {
   char l[15],r[15],flg[10];
   cin>>l>>r>>flg;
   int ll=strlen(l);
   int lr=strlen(r);
   if(flg[0]=='e')  //如果是even,两边全真
   {
    for(j=0;j<ll;j++)
     True[l[j]-'A']=1;
    for(j=0;j<lr;j++)
     True[r[j]-'A']=1;
   }
   else if(flg[0]=='u') //up 两边没出现的全真,左重右轻
   {
    int vis[15]={0};
    for(j=0;j<ll;j++)
    {
     vis[l[j]-'A']=1;
     heavy[l[j]-'A']=1;
     if(light[l[j]-'A'])
      True[l[j]-'A']=1;
    }
    for(j=0;j<lr;j++)
    {
     vis[r[j]-'A']=1;
     light[r[j]-'A']=1;
     if(heavy[r[j]-'A'])
      True[r[j]-'A']=1;
    }
    for(j=0;j<12;j++)
     if(!vis[j])
      True[j]=1;
   }
   else    //左倾有种
   {
    int vis[15]={0};
    for(j=0;j<ll;j++)
    {
     vis[l[j]-'A']=1;
     light[l[j]-'A']=1;
     if(heavy[l[j]-'A'])
      True[l[j]-'A']=1;
    }
    for(j=0;j<lr;j++)
    {
     vis[r[j]-'A']=1;
     heavy[r[j]-'A']=1;
     if(light[r[j]-'A'])
      True[r[j]-'A']=1;
    }
    for(j=0;j<12;j++)
     if(!vis[j])
      True[j]=1;
   }
  }
  for(i=0;i<12;i++)
   if(!True[i]) //找到那个假的
   {
    if(heavy[i])
     printf("%c is the counterfeit coin and it is heavy.\n",i+'A');
    else
     printf("%c is the counterfeit coin and it is light.\n",i+'A');
    break;
   }
 }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值