poj3045 贪心

27 篇文章 0 订阅

 

 

如题http://poj.org/problem?id=3045

 

Cow Acrobats
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3425 Accepted: 1333

Description

Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts.

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack.

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

Input

* Line 1: A single line with the integer N.

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i.

Output

* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

Sample Input

3
10 3
2 5
3 3

Sample Output

2

Hint

OUTPUT DETAILS:

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.

Source

 

 

思路:题目要求确定一个序列使得这个序列最大风险在所有可能的序列中最小。对于任意的A,B牛,设他们上面的牛的总重量是m。

假设最优方案为A下B上。

 

R=m+WB-SA.

如果交换位置,有R‘=m+WA-SB.

有R<R' 则WB+SB<WA+SA.

 

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 50005
#define inf 0x7fffffff
#define max(a,b)(a>b?a:b)

struct node
{
 int w,s;
};
node a[MAXN];


bool operator<(node a,node b)
{
 return a.w+a.s>b.w+b.s;
}

int main()
{
// freopen("C:\\1.txt","r",stdin);
 int N;
 cin>>N;
 int i;
 int sum=0;
 for(i=0;i<N;i++)
 {
  cin>>a[i].w>>a[i].s;
  sum+=a[i].w;
 }
 sort(a,a+N);
 int t=0;
 int res=-inf;
 for(i=0;i<N;i++)
 {
  res=max(res,sum-t-a[i].w-a[i].s);
  t+=a[i].w;
 }
 cout<<res<<endl;
 return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值