poj3111 二分最大化平均值

27 篇文章 0 订阅

 

如题:http://poj.org/problem?id=3111

K Best
Time Limit: 8000MS Memory Limit: 65536K
Total Submissions: 7073 Accepted: 1848
Case Time Limit: 2000MS Special Judge

Description

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1, i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ kn ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3

Sample Output

1 2

Source

Northeastern Europe 2005, Northern Subregion

 

 

 

思路:选取k个最大化平均值的思路在我上一篇,这里不再赘述。在不断缩小区间的过程中,满足最后一个精度的前k个元素也就是结果。循环100次超时,循环50次6秒。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 100005

struct node
{
 int v,w,id;
};
node a[MAXN];
struct node1
{
 double value;
 int id;
}b[MAXN];

bool operator<(node1 x,node1 y)
{
 return x.value>y.value;
}

int C(double x,int k,int n)
{
 int i;
 for(i=0;i<n;i++)
 {
  b[i].value=a[i].v-x*a[i].w;
  b[i].id=a[i].id;
 }
 sort(b,b+n);
 double sum=0;
 for(i=0;i<k;i++)
 {
  sum+=b[i].value;
 }
 return sum>=0;
}
int cmp(node1 x,node1 y)
{
 return x.id<y.id;
}

int main()
{
// freopen("C:\\1.txt","r",stdin);
 int n,k;
 cin>>n>>k;
 int i;
 double l=0,r=0;
 for(i=0;i<n;i++)
 {
  cin>>a[i].v>>a[i].w;
  a[i].id=i+1;
  r+=a[i].v;
 }
 for(i=0;i<50;i++)
 {
  double mid=(l+r)/2;
  if(C(mid,k,n))
   l=mid;
  else
   r=mid;
 }
 sort(b,b+k,cmp);
 for(i=0;i<k;i++)
 {
  printf("%d%c",b[i].id,i==k-1?'\n':' ');
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值