POJ 1456 SuperMarket

Supermarket
Time Limit: 2000MS
Memory Limit: 65536K
Total Submissions: 13144
Accepted: 5882
Description
A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10
Sample Output
80
185
Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
Source
Southeastern Europe 2003

题意:有N种商品,每种商品的价值和过期时间,每次只能选一种商品卖,每种商品消耗一单位时间,问最大利润

做法:先把商品按照价值大小排序,价值相同按ddl从小到大(ddl小的要先卖),然后再遍历一遍,如果一个商品的父节点不等于0,说明在ddl之前还有时间卖这种产品,就把它的父节点的父节点设成父节点的前一天,意义为可以在这么多天内卖掉,得到的就是最大利润;

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdio>
#define maxn 10010
#define inf 0x3f3f3f3f3f
using namespace std;
int n;
struct Node
{
    int v,d;
};

Node node[maxn];
bool cmp(const Node& a,const Node & b)
{
    if(a.v==b.v)
    return a.d<b.d;
   return a.v>b.v;

}
int pre[maxn];

int fr(int x)
{
    int r=x;
    while(r!=pre[r])
    {
        r=pre[r];
    }
    int j=x;
    while(x!=r)
    {
        j=pre[x];
        pre[x]=r;
        x=j;
    }
    return r;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&node[i].v,&node[i].d);
        }
        for(int i=0;i<maxn;i++)pre[i]=i;
        sort(node,node+n,cmp);
        int ans=0;
        for(int i=0;i<n;i++)
        {
            int r=fr(node[i].d);
            if(r!=0)
            {
                pre[r]=r-1;
                ans+=node[i].v;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值