A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 111585 Accepted: 34748
Case Time Limit: 2000MS
Description
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.
Source
POJ Monthly–2007.11.25, Yang Yi
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#define maxn 111111
using namespace std;
typedef long long ll;
ll num[maxn];
ll segtree[maxn*20];
ll add[maxn*20];
void init(int n)
{
for(int i=1;i<=n;i++)
{
segtree[i]=0;
}
}
void PushDown(int rt,int l)
{
if(add[rt]!=0)
{
add[rt<<1]+=add[rt];
add[rt<<1|1]+=add[rt];
segtree[rt<<1]+=(l-(l>>1))*add[rt];
segtree[rt<<1|1]+=(l>>1)*add[rt];
add[rt]=0;
}
}
void plant(ll left,ll right,ll rt)
{
add[rt]=0;
if(left==right)
{
scanf("%I64d",&segtree[rt]);
return ;
}
ll mid=(left+right)>>1;
plant(left,mid,rt<<1);
plant(mid+1,right,rt<<1|1);
segtree[rt]=segtree[rt<<1]+segtree[rt<<1|1];
}
ll query(ll left,ll right,ll rt,ll L,ll R)
{
if(L<=left&&right<=R)
{
return segtree[rt];
}
PushDown(rt,right-left+1);
ll mid=(left+right)/2;
ll ans=0;
if(L<=mid)
ans+=query(left,mid,rt<<1,L,R);
if(R>mid)
ans+=query(mid+1,right,rt<<1|1,L,R);
return ans;
}
void update(ll left,ll right,ll rt,ll l,ll r,ll up)
{
if(l<=left&&r>=right)
{
segtree[rt]+=(ll)up*(right-left+1);
add[rt]+=up;
return;
}
PushDown(rt,right-left+1);
int mid=(left+right)>>1;
if(l<=mid)update(left,mid,rt<<1,l,r,up);
if(r>mid)update(mid+1,right,rt<<1|1,l,r,up);
segtree[rt]=segtree[rt<<1]+segtree[rt<<1|1];
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(segtree,0,sizeof(segtree));
memset(add,0,sizeof(add));
plant(1,n,1);
ll a,b,c;
char op[10];
for(int i=0;i<m;i++)
{
scanf("%s",op);
if(op[0]=='Q')
{
scanf("%I64d%I64d",&a,&b);
printf("%I64d\n",query(1,n,1,a,b));
}
else
{
scanf("%I64d%I64d%I64d",&a,&b,&c);
update(1,n,1,a,b,c);
}
}
}
return 0;
}