HDU 1260 Tickets(DP)

Tickets

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4513 Accepted Submission(s): 2320

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input
2
2
20 25
40
1
8

Sample Output
08:00:40 am
08:00:08 am

Source
浙江工业大学第四届大学生程序设计竞赛

Recommend
JGShining

题意:有N个人排队买票,可以一个人买,可以两相邻的人一起买,给出每个人买票的时间和每两个相邻的人买票的时间,使得买票的总时间最短。

做法:dp
dp[i]表示前i个人买票的最短时间且只有i个人,则对于第i个人来说,可以单独买,可以和他前面的人一起买
dp[i]=min(dp[i-2]+aj[i-1],dp[i-1]+s[i])

和那题删一个数字取它相邻的数字很相像,这是按照现阶段决策确定的dp

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define maxn 10010
using namespace std;
const int inf=0x3f3f3f3f3f;
int dp[maxn];
int aj[maxn];
int s[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    int n;
    while(t--)
    {
        scanf("%d",&n);

        for(int i=1;i<=n;i++)
        {
            scanf("%d",&s[i]);
        }
        memset(dp,inf,sizeof(dp));
        dp[0]=0;
        for(int i=1;i<=n-1;i++)
        {
            scanf("%d",&aj[i]);
        }
        dp[1]=s[1];
        for(int i=2;i<=n;i++)
        {
            dp[i]=min(dp[i-2]+aj[i-1],dp[i-1]+s[i]);
        }
        int ans=dp[n];
        int h=ans/3600;
        int m=(ans/60)%60;
        int s=ans%60;
        h+=8;
        if(h<10)printf("0%d:",h);else printf("%d:",h);
        if(m<10)printf("0%d:",m);else printf("%d:",m);
        if(s<10)printf("0%d",s);else printf("%d",s);
        if(h>12)printf(" pm\n");else printf(" am\n");

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值