[POJ2241]最高巴比伦塔

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this talehave been forgotten. So now, in line with the educational nature of this contest, we will tell you thewhole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type.Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block couldbe reoriented so that any two of its three dimensions determined the dimensions of the baseand the other dimension was the height.

They wanted to construct the tallest tower possible by stacking blocks. The problem wasthat, in building a tower, one block could only be placed on top of another block as long asthe two base dimensions of the upper block were both strictly smaller than the correspondingbase dimensions of the lower block. This meant, for example, that blocks oriented to haveequal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians canbuild with a given set of blocks.InputThe 

input 

file will contain one or more test cases. The first line of each test case contains an integer n,representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.OutputFor each test case, print one line containing the case number (they are numbered sequentially startingfrom 1) and the height of the tallest possible tower in the format‘Case case: maximum height = height’

Sample Input

1

10 20 30

2

6 8 10

5 5 5

7

1 1 1

2 2 2

3 3 3

4 4 4

5 5 5

6 6 6

7 7 7

5

31 41 59

26 53 58

97 93 23

84 62 64

33 83 27

0

Sample Output

Case 1: maximum height = 40

Case 2: maximum height = 21

Case 3: maximum height = 28

Case 4: maximum height = 342

题意:有n(n≤30)种立方体,每种都有无穷多个。要求选一些立方体摞成一根尽量高的柱子(可以自行选择哪一条边作为高),使得每个立方体的底面长宽分别严格小于它下方立方体的底面长宽。

题解:按长宽高的不同排列将1个立方体看成6个不同立方体

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=185;
int n, dp[N], ans, cas;
struct node{ int a, b, c; }cubic[N];

bool cmp( node a, node b ){ return a.a<b.a; }

int main() {
	while( ~scanf( "%d", &n ) ) {
		if( !n ) break;
		ans=0;
		memset( dp, 0, sizeof dp );
		for( int i=1; i<=n; i++ ) {
			scanf( "%d%d%d", &cubic[i].a, &cubic[i].b, &cubic[i].c );
			cubic[i+n].a=cubic[i].a;    cubic[i+n].b=cubic[i].c;    cubic[i+n].c=cubic[i].b;
			cubic[i+n*2].a=cubic[i].b; cubic[i+n*2].b=cubic[i].a; cubic[i+n*2].c=cubic[i].c;
			cubic[i+n*3].a=cubic[i].b; cubic[i+n*3].b=cubic[i].c; cubic[i+n*3].c=cubic[i].a;
			cubic[i+n*4].a=cubic[i].c; cubic[i+n*4].b=cubic[i].a; cubic[i+n*4].c=cubic[i].b;
			cubic[i+n*5].a=cubic[i].c; cubic[i+n*5].b=cubic[i].b; cubic[i+n*5].c=cubic[i].a;
		}
		n*=6;
		sort( cubic+1, cubic+n+1, cmp );
		for( int i=1; i<=n; i++ )
			for( int j=0; j<i; j++ )
				if( cubic[i].a>cubic[j].a && cubic[i].b>cubic[j].b )
					dp[i]=max( dp[i], dp[j]+cubic[i].c );
		for( int i=1; i<=n; i++ )
			ans=max( ans, dp[i] );
		printf( "Case %d: maximum height = %d\n", ++cas, ans );
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值