贪心算法——Saruman‘s Army(POJ 3069)

题目连接

http://poj.org/problem?id=3069

Saruman‘s Army(POJ 3069)

题目描述

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题目限制

Time Limit: 1000MS Memory Limit: 65536K

思路

每次首先找到没有被覆盖的最左边的点,然后在以此点为起点向右半径为R的右邻域内找到邻域内最右边的点,将这个点标记。然后再从这个标记的点的后面一个点开始重复上述操作。注意:首先对输入的位置信息排序。

代码

#include<iostream>
#include<algorithm>
using namespace std;

const int MAX_N = 1000;
int N,R;  //定义直线上有N个点,范围距离为R
int X[MAX_N]; //定义直线上的位置信息

void solve()
{
    //首先对输入的位置信息进行排序
    sort(X,X+N);
    
    int i=0,ans=0;   //i为计数器,ans为最终确定的点数

    while(i < N)    //每到确定点的右侧邻域最远的点后,进行下一次循环
    {
        
        //首先找到直线最左边的点
        int s = X[i++]; //s是没有覆盖的最左边的点

        //根据这个点向右找到右边邻域最右侧的点 
        while(i < N && X[i] <= s+R) i++;       //条件i<N !!

        //新标记的点
        int p = X[i-1];

        //下一步向右前进到距p的距离大于R的点
        while(i < N &&  X[i] <= p+R) i++;       //条件i<N !!

        ans++;
    }

    cout<<ans<<endl;
}

int main()
{
    while(cin>>R>>N && R != -1 && N != -1)
    {
        for(int i=0;i<N;i++)  
            cin>>X[i];
        solve();
    }
    return 0;
}

总结

贪心的目标是半径为R的邻域的中心,使得覆盖点数最多(开始没想法,依旧菜鸡)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值