【C语言】PAT甲级训练题目 1093题总结

其他题目:【C语言】PAT甲级训练题目答案、知识点梳理及总结

链接:原题

原题内容:

1093 Count PAT's (25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

 思路:

很简单的一道题目,看到之后马上想到了n^3、n^2的算法,但是题目对于时间要求较为苛刻,因此开始考虑节省时间,尽量在一个循环内完成,写草稿后可简单地发现,只要在每次T出现的时候累加之前所有的P和A组合的可能性即可。

因此每当P和A出现的时候,要计算出当前所有的PA的可能,方便T出现时累加,按照这个思路,

程序就可以在O(n)的情况下完成。

代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int j=0;
    long long count1=0;
    long long result=0,temp=0;
    char pat[100000];
    scanf("%s",pat);
    int len=strlen(pat);
    for(int i=0;i<len;i++)
    {
        if(pat[i]=='P')
            count1++;
        if(pat[i]=='A')
        {
            temp=temp+count1;
            j++;
        }
        if(pat[i]=='T')
            result+=temp;
    }
    result%=1000000007;
    printf("%lld",result);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值