【C语言】PAT甲级训练题目 1004题总结

其他题目:【C语言】PAT甲级训练题目答案、知识点梳理及总结

链接:原题

原题内容:

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

思路:

就是一个BFS的广搜,顺便要记录叶节点的数量,用队列存储每层遍历节点,再递归访问就行了。

但是这道题目有点坑,我不知道是我的思路有误,还是它出题没考虑这么多,又是两个测试点始终过不去,解决无果,无奈去搜别人的答案,一一对照,发现这种结果的输出

Sample Input2:

2 2
01 2 03 03
01 2 03 03

Sample Output2:

0 4

出来的结果是0 4,而不是0 1,也就是说单独存储节点如果反复出现,也要分开记录,节点的ID是可以重复的,推测测试点1,3均要满足此条件。

并且输入数值总节点数和非叶节点数即便不按照逻辑来, 如非叶节点数数量比总结点数更大也无妨,只要你写好输入的循环就行了。错误的输入造成的错误的输出也是正确结果。

还有就是测试点3,我始终不明白The input ends with N being 0. That case must NOT be processed.这句话的意思,为什么还要有输出,还是1?这样才能过测试点3。

Sample Input3:

0 0

Sample Output3:

1

 代码:

因为没写出来满分答案,就把一个网上别人的答案先放着好了,冒犯的话就删掉,不好意思。

#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>
using namespace std;
vector<int> v[100];
int book[100], maxdepth = -1;
void dfs(int index, int depth) {
	if (v[index].size() == 0) {
		book[depth]++;
		maxdepth = max(maxdepth, depth);
		return;
	}
	for (int i = 0; i < v[index].size(); i++)
		dfs(v[index][i], depth + 1);
}
int main() {
	int n, m, k, node, c;
	scanf("%d %d", &n, &m);
	for (int i = 0; i < m; i++) {
		scanf("%d %d", &node, &k);
		for (int j = 0; j < k; j++) {
			scanf("%d", &c);
			v[node].push_back(c);
		}
	}
	dfs(1, 0);
	printf("%d", book[0]);
	for (int i = 1; i <= maxdepth; i++)
		printf(" %d", book[i]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值