【C语言】PAT甲级训练题目 1001题总结

其他题目:【C语言】PAT甲级训练题目答案、知识点梳理及总结​​​​​​​

链接:原题

原题内容:

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where -10​≤a,b≤10​​​. 

The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

答案:

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int i,j,a,b,sum,num1,num2;
    int num[8];
    i=0;
    scanf("%d%d",&a,&b);
    sum=a+b;
    if(sum<0)
        printf("-"); 
    if(sum==0){
      printf("0");
      exit(0);   //special
    }
    while(sum)
    {
        num[i]=abs(sum%10);
        i++;
        sum/=10;
    }
    for (j=i-1;j>=0;j--)
    {
        printf("%d",num[j]);
        if(j%3==0 && j!=0)
            printf(",");
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值