POJ2560 Freckles(求最小生成树的权值Prim写法)

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.
Input
The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.
Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.
Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0
Sample Output
3.41


题意:给出n,以及n个点的坐标(都是实数),求构造出的最小生成树的权值是多少。


解题思路:

Prim模板

直接把上一题的代码拿来用了...

POJ2349 Arctic Network(手动翻译)(求最小生成数权值第几大的边 Prim写法)


AC代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;

#define INF 0x3f3f3f3f

struct node
{
	double x,y;
} q[110];

double mp[110][110],dis[110];
int book[110],n,m;

void prim()
{
	double sum=0;
	for(int i=1;i<=n;i++)
	{
		dis[i]=mp[1][i];
	}
	dis[1]=0;
	book[1]=1;
	for(int i=1;i<=n-1;i++)
	{
		double minn=INF;
		int u;
		for(int j=1;j<=n;j++)
		{
			if(dis[j]<minn&&book[j]==0)
			{
				minn=dis[j];
				u=j;
			}
		}
		sum+=minn;
		book[u]=1;
		for(int j=1;j<=n;j++)
		{
			if(mp[u][j]<dis[j]&&book[j]==0)
			{
				dis[j]=mp[u][j];
			}
		}
	}
	printf("%.2f\n",sum);
}

int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%lf%lf",&q[i].x,&q[i].y);
		}
		for(int i=1;i<=n;i++)
		{
			dis[i]=INF;
			for(int j=1;j<=n;j++)
			{
				if(i==j) mp[i][j]=0;
				else mp[i][j]=INF;
			}
		}
		memset(book,0,sizeof(book));
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				mp[i][j]=sqrt((q[i].x-q[j].x)*(q[i].x-q[j].x)+(q[i].y-q[j].y)*(q[i].y-q[j].y));
			}
		}
		prim();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值