poj2528——Mayor's posters(离散化+区间覆盖)

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.
Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.
Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
这里写图片描述
Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
Sample Output

4

给出一些区间,要按顺序将这些区间贴上海报,因此有些海报会被覆盖,求最终能看到多少种海报,只能看到一部分的也算。
可以用线段树来解决,贴着海报的区间用一个独一无二的值覆盖,最后查询整个区间有多少种覆盖的值就行。但问题是题目的值很大,直接按照给的区间去覆盖肯定会超时,因此要离散化,只需要知道端点的值就够了,将这些端点保存下来,照它们的相对位置去覆盖,比如覆盖1~10,1000~2000和覆盖1~2,3~4就没区别。
但还有个问题就是这种离散化之后会丢失中间的数据,假如有三张海报,第一张很长,剩下两张正好覆盖在海报的两端,中间的部分会露出来,这样的情况一般的离散化之后只会算出两张,因为中间没有数据,后面的两张挤到一起去了,神奇的是这样poj也能过,这明显是不对的。所以要给每个区间都再加一个右端点+1的数,防止这种情况。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <ctime>
#define INF 0x3f3f3f3f
#define MAXN 100005
#define Mod 1000000007
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int col[MAXN<<3],hsh[MAXN<<3],li[MAXN],ri[MAXN];
int n,vis[MAXN<<3],ans;
void pushdown(int rt)
{
    if(col[rt]!=-1)
    {
        col[rt<<1]=col[rt<<1|1]=col[rt];
        col[rt]=-1;
    }
}
int binsearch(int num,int n,int a[])
{
    int low=0,high=n-1,mid;
    while(low<=high)
    {
        mid=(low+high)>>1;
        if(a[mid]==num)
            return mid;
        else if(a[mid]<num)
            low=mid+1;
        else
            high=mid-1;
    }
    return -1;
}
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        col[rt]=c;
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(L<=m)
        update(L,R,c,lson);
    if(R>m)
        update(L,R,c,rson);
}
void query(int l,int r,int rt)
{
    if(col[rt]!=-1)
    {
        if(!vis[col[rt]])
            ans++;
        vis[col[rt]]=1;
        return;
    }
    if(l==r)
        return;
    int m=(l+r)>>1;
    query(lson);
    query(rson);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(col,-1,sizeof(col));
        int n,nn=0;
        scanf("%d",&n);
        for(int i=0; i<n; ++i)
        {
            scanf("%d%d",&li[i],&ri[i]);
            hsh[nn++]=li[i];
            hsh[nn++]=ri[i];
        }
        sort(hsh,hsh+nn);
        int m=1;
        for(int i=1; i<nn; ++i)
        {
            if(hsh[i]!=hsh[i-1])
                hsh[m++]=hsh[i];
        }
        for(int i=m-1;i>0;--i)
        {
            if(hsh[i]!=hsh[i-1]+1)
                hsh[m++]=hsh[i-1]+1;
        }
        sort(hsh,hsh+m);
        for(int i=0; i<n; ++i)
        {
            int l=binsearch(li[i],m,hsh);
            int r=binsearch(ri[i],m,hsh);
            update(l,r,i,0,m-1,1);
        }
        memset(vis,0,sizeof(vis));
        ans=0;
        query(0,m-1,1);
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值