POJ 2528(线段树)-Mayor's posters

题目:

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 

  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

 

题目大意:在墙面上贴海报,但是先贴的海报可能会被之后贴的海报所覆盖,问完成n次操作后,还能看到几张海报(海报的全部或一部分)。

思路:可以从后忘前遍历。已经贴上的区间则不能在贴了。还有因为本题的数据过大,所以还要采用离散化。

AC代码:

#include<iostream> //由后向前更新 
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<vector>
#define Max 1e17
#define ll long long
using namespace std;
const int INF=1e5+5;
int n,t;
struct node{
	int id;
	int d;
}g[INF];
struct Node{
	int right;
	int left;
	int mp; 
}f[4*INF];
int a[10000005],aa[2*INF];
bool cmp(node p,node q)
{
	if(p.d ==q.d )return p.id <q.id ;
	else return p.d >q.d ;
}
//建树 
void built(int ans,int l,int r)
{
	f[ans].left =l;f[ans].right =r;
	f[ans].mp =0;
	if(l==r)return;
	int mid=(l+r)/2;
	built(ans<<1,l,mid);
	built(ans<<1|1,mid+1,r);
}
bool find(int ans,int l,int r)//如果根据每个砖块来判断会超时 
{
	bool v,u=false;
	if(f[ans].mp ==1)return false;//已放过区间中的任何区间都失效了 
	if(l==f[ans].left &&r==f[ans].right ){
		f[ans].mp =1;return true;
	}
	int mid=(f[ans].left +f[ans].right )/2;
	if(r<=mid)v=find(ans<<1,l,r);
	else if(l>mid)v=find(ans<<1|1,l,r);
	else {
		v=find(ans<<1,l,mid);
		u=find(ans<<1|1,mid+1,r);//这样做能使两个函数
		//执行彻底,因为或,前面的成立后面的就不执行了 
	}
	if(f[ans<<1].mp &&f[ans<<1|1].mp ){
		f[ans].mp =1;//更新区间
	}
	return v||u; 
}
int main()
{
	cin>>t;
	while(t--)
	{
		scanf("%d",&n);
		int i,j,k;
		for(i=0,j=1;i<n;i++)
		{
			scanf("%d%d",&g[i].d ,&g[i].id );//读进的是板块号,而不是边界 
			aa[j++]=g[i].d ;aa[j++]=g[i].id ;
		}
		sort(aa+1,aa+j);
		int cnt=unique(aa+1,aa+j)-aa-1;//去重 
		for(i=1;i<=cnt;i++)
		{
			a[aa[i]]=i;//离散化 
		}
		built(1,1,cnt);
		int sum=0;
		for(i=n-1;i>=0;i--)
		{
			if(find(1,a[g[i].d ],a[g[i].id ]))sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值