杭电 acm 1108 最小公倍数

最小公倍数
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63817    Accepted Submission(s): 35181






Problem Description


给定两个正整数,计算这两个数的最小公倍数。


 




Input


输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.


 




Output


对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。




 




Sample Input


10 14




 




Sample Output


70




 




Source


 POJ 






#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
	int a,b;
	while(cin>>a>>b)
	{
		int x=a,y=b;
		if(y>x)
		{
			int temp=x;
			x=y;
			y=temp;
		}
		while(x%y!=0)
		{
			int temp=x%y;
			x=y;y=temp;
		}
		cout<<((a*b)/y)<<endl;
	}
	
}





辗转相除 最小公倍数等于乘积减去最大公约数
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值