kuangbin专题一 简单搜索 B - Dungeon Master

B - Dungeon Master

 

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!

有六个方向分别是上一层下一层上下左右,标记已经经过的点,三层bfs。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int t[35][35][35],L,R,C;
int dir[6][3]={{0,1,0},{0,-1,0},{0,0,1},{0,0,-1},{1,0,0},{-1,0,0}};
int x1,y1,z1,x2,y2,z2,s;
char map[35][35][35];
struct where{
	int x,y,z;
	int sum;
};
void bfs(){
	queue <where> a;
	where start;
	start.x=x1;
	start.y=y1;
	start.z=z1;
	start.sum=0;
	a.push(start);
	while(!a.empty()){
	where e;
	e=a.front();
	a.pop();
	int x2=e.x;
	int y2=e.y;
	int z2=e.z;
	int s=e.sum;
	if(map[x2][y2][z2]=='E'){
		cout<<"Escaped in "<<s<<" minute(s)."<<endl;
		return ;
	}
	for(int i=0;i<6;i++){
		where temp;
		int xi=temp.x=x2+dir[i][0];
		int yi=temp.y=y2+dir[i][1];
		int zi=temp.z=z2+dir[i][2];
		temp.sum=s+1;
		if(xi<1||xi>L||yi<1||yi>R||zi<1||zi>C) continue;
		if(map[xi][yi][zi]!='#'&&!t[xi][yi][zi]){
			t[xi][yi][zi]=1;
			a.push(temp);
		}
	}
}

	cout<<"Trapped!"<<endl;
}
int main() 
{
	while(cin>>L>>R>>C){
		if(L==0&&R==0&&C==0)	break;
		memset(t,0,sizeof(t));
		memset(map,0,35);
	    for(int i=1;i<=L;i++)
	    	for(int j=1;j<=R;j++)
	    		for(int k=1;k<=C;k++){
	    			cin>>map[i][j][k];
	    			if(map[i][j][k]=='S')
	    			{x1=i;y1=j;z1=k;
					      }
	    			
			}
		bfs();      
		}
return 0;
}

学会了使用一直长久以来不会熟练使用的东西队列以及结构体的定义,对bfs加深了理解,今天学习效率非常高,贼恐怖,以前好久没看懂的东西,今天一下就看懂了,虽然也用了很久但是记住了。

queue:

pop删除顶端元素;

push()插入;

front()读取顶端元素;

struct 定义结构体;

queue<s> a;

创建结构为s的a队列;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值