Description
给出一个 n n 个点条边的无向图 G=(V,E) G = ( V , E ) ,对于 V V 的一个四元子集,和 E E 的一个五元子集,两者组成 G G 的一个子图,问该种子图的个数,两个子图相同当且仅当 V1=V2,E1=E2 V 1 = V 2 , E 1 = E 2
Input
多组用例,每组用例首先输入两个整数 n,m n , m 表示点数和边数,之后 m m 行每行输入两个整数表示一条无向边
(2≤n≤105,1≤m≤min(2⋅105,n(n−1)2)) ( 2 ≤ n ≤ 10 5 , 1 ≤ m ≤ m i n ( 2 ⋅ 10 5 , n ( n − 1 ) 2 ) )
Output
输出 G G 的这种特殊子图个数
Sample Input
4 5
1 2
2 3
3 4
4 1
1 3
4 6
1 2
2 3
3 4
4 1
1 3
2 4
Sample Output
1
6
Solution
只要求出含边的三元环个数 cntx,y c n t x , y ,答案即为 ∑x<ycntx,y(cntx,y−1)2 ∑ x < y c n t x , y ( c n t x , y − 1 ) 2
用 set s e t 存下所有的边,枚举 x x ,把所有的邻接点 z z 打上的标记,之后枚举 x x 的邻接点,如果 y y 的度数不超过,则直接暴力枚举 x x 的邻接点,如果 z z 带上了的标记则 x,y,z x , y , z 构成一个三元环,如果 y y 的度数超过,枚举 x x 的邻接点,如果 y,z y , z 这条边在 set s e t 里则 x,y,z x , y , z 构成三元环,时间复杂度 O(mlog2m) O ( m l o g 2 m )
Code
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<set>
using namespace std;
typedef long long ll;
#define maxn 100005
set<ll>s;
int n,m,vis[maxn],link[maxn];
vector<int>g[maxn];
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=1;i<=n;i++)g[i].clear(),vis[i]=0,link[i]=0;
s.clear();
int N=(int)sqrt(m+0.5);
for(int i=1;i<=m;i++)
{
int u,v;
scanf("%d%d",&u,&v);
g[u].push_back(v),g[v].push_back(u);
s.insert((ll)n*u+v),s.insert((ll)n*v+u);
}
ll ans=0;
for(int x=1;x<=n;x++)
{
vis[x]=1;
for(int i=0;i<g[x].size();i++)link[g[x][i]]=x;
for(int i=0;i<g[x].size();i++)
{
int cnt=0;
int y=g[x][i];
if(vis[y])continue;
if(g[y].size()<=N)
{
for(int j=0;j<g[y].size();j++)
{
int z=g[y][j];
if(link[z]==x)cnt++;
}
}
else
{
for(int j=0;j<g[x].size();j++)
{
int z=g[x][j];
if(s.find((ll)n*y+z)!=s.end())cnt++;
}
}
ans+=(ll)cnt*(cnt-1)/2;
}
}
printf("%I64d\n",ans);
}
return 0;
}