POJ - 2406 Power Strings

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:给出一个字符串 问它最多由多少相同的字串组成。

分析:  KMP求最小周期——结论:如果一个字符串有最小周期,那么最小周期为n-next[n]
          n%(n-next[n])就是最小循环节的最大循环次数。

代码
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[1000010];
int next[1000010];//next[i]表示i长度的匹配串所拥有的 最长相同的 前缀后缀的 长度
void get(char s[],int next[],int len)
{
    next[0]=-1;
    int i=0;
    int j=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])// 当前位置匹配
        {
            i++;      //移动到下一位置
            j++;      //匹配个数+1
            next[i]=j;
        }
        else
            j=next[j]; //回溯
    }
}
int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='.')
            break;
        memset(next,0,sizeof(next));
        int len=strlen(s);
        get(s,next,len);
        int sum=1;
        if(len%(len-next[len])==0)
            sum=len/(len-next[len]);
        printf("%d\n",sum);
    }
}

 

 

 

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值