1017. Queueing at Bank (25)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which divides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
算法分析:这题主要还是考察结构体的排序。首先开一个窗口数组,用来存储窗口的工作时长,从银行上班开始计算,初始化为0。客户等待的时间就是用窗口工作的时长减去客户到达的时间(这个时间是相对于8点而言的),因为客户到达时间大于窗口的工作时间,那么客户是不用等待的。更详细的说明见代码注释。

#include <stdio.h>
#include <stdlib.h>

typedef struct Custom *tmp;
struct Custom
{
    int hh, mm, ss;
    int process;
}cus[10000];

int cmp(const void *a, const void *b) //按到达银行的时间,从早到晚排序
{
    tmp aa = (tmp)a;
    tmp bb = (tmp)b;
    if(aa->hh != bb->hh)
        return aa->hh > bb->hh;
    else if(aa->mm != bb->mm)
        return aa->mm > bb->mm;
    else
        return aa->ss > bb->ss;
}

int main()
{
    int window[100] = {0};
    int n, k, i, j, wait = 0; //wait按秒计数
    scanf("%d %d", &n, &k);
    for(i = 0; i < n; i++)
        scanf("%d:%d:%d %d", &cus[i].hh, &cus[i].mm, &cus[i].ss, &cus[i].process);
    qsort(cus, n, sizeof(cus[0]), cmp); //排序
    for(i = 0; i < n; i++)
    {
        int index = 0, tmp;
        tmp = (cus[i].hh - 8) * 3600 + cus[i].mm * 60 + cus[i].ss;
        if(tmp > 9 * 3600) //来的太晚,银行关门了
            break;
        for(j = 0; j < k; j++) //找到最早空出来的窗口的编号(0到k-1)
        {
            if(window[j] < window[index])
                index = j;
        }
        if(window[index] >= tmp) //计算出客户等待的时间,并更新窗口的工作时长
        {
            wait += window[index] - tmp;
            window[index] += cus[i].process * 60;
        }
        else
            window[index] = tmp + cus[i].process * 60;
    }
    if(i != 0) //这里有两种情况,全天没有一个客户,或者所有的客户都来的太晚,那么分母就为0printf("%.1f", wait / (i * 60.0));
    else
        printf("0.0");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值