1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 &lt; N &lt; 100 0&lt;N&lt;100 0<N<100, the number of nodes in a tree, and M ( &lt; N ) M (&lt;N) M(<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K K K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01 01 01.

The input ends with N N N being 0 0 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1


解题思路:

要求输出每层的叶子结点个数,通过所给的结点关系构建树即可。由于不知道每个节点有多少个孩子,所以使用队列来存储子树节点。在确定根节点后,在遍历每一层即可,详见代码
本题的思路清晰,熟练掌握树的构建,注意细节即可;


#include <iostream>
#include <iomanip>
#include <queue>
using namespace std;

struct TreeNode {
	queue<int> child;
};

int main()
{
	int N, M;
	int visit[100] = { 0 };
	int root;
	TreeNode T[100];
	cin >> N >> M;
	for (int i = 0; i < M; i++) {
		int ID, K, temp;
		cin >> ID >> K;
		for (int j = 0; j < K; j++) {
			cin >> temp;
			T[ID].child.push(temp);		// 数组下标表示结点ID
			visit[temp]++;
		}
	}
	// 查找根节点
	for (int i = 1; i < N; i++) {		// N != 0
		if (!visit[i]) {
			root = i;
			break;
		}
	}

	if (N == 1)		// 只有一个节点的情况
		cout << "1" << endl;
	else {
		queue<int> q = T[root].child;
		cout << "0";
		while (!q.empty()) {
			int cont = 0;	// 记录叶子结点个数
			int size = q.size();
			for (int i = 0; i < size; i++) {
				int temp = q.front();
				q.pop();
				if (T[temp].child.empty())
					cont++;
				else {
					queue<int> t = T[temp].child;
					while (!t.empty()) {
						q.push(t.front());
						t.pop();
					}
				}
			}
			cout << " " << cont;
		}
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值