1016 Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 24 24 non-negative integers denoting the toll (cents/minute) from 00 : 00 − 01 : 00 00:00 - 01:00 00:0001:00, the toll from 01 : 00 − 02 : 00 01:00 - 02:00 01:0002:00, and so on for each hour in the day.

The next line contains a positive number N ( ≤ 1000 ) N (≤1000) N(1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date ( m m : d d : h h : m m ) (mm:dd:hh:mm) (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题解:

模拟题,按部就班去做即可。。切忌烦躁,一些值得借鉴的点:

  1. 利用 set 存储时间可以自动排序(升序)
  2. 里用 map 存储 string 类型 同样也可以自动排序(字典升序)
  3. 所以每个客户利用map< string, Customer> 来存储即可,后者为自定义结构体;
  4. 计算账单可以按照两个时间的全天计算,然后相减即可;
  5. 坑点:题目中说保证一定有一对记录会配对是指所有记录中至少有一个配对,而并不是指每一个客户都会有一对记录会配对,因此输出前应该先判断时候有配对,否则不用输出任何东西,如果不考虑这个第二,三个测试点会过不了;
    参考:
    柳婼 の blog
    Jack_Wang822

备注:代码是我自己写的,计算账单是借鉴的第一个链接,坑点是看的第二个链接;


#include <iostream>
#include <map>
#include <set>
#include <string>
#include <cstdio>
#include <iomanip>
using namespace std;

struct Customer{
    string name;
    set<pair<string,string> > time;     // 利用set存储时间自动排序
    string month;
};
int rate[25] = {0};

double billFromZero(int day, int hour, int minute) {
    double total = rate[hour] * minute + rate[24] * 60 * day;
    for (int i = 0; i < hour; i++)
        total += rate[i] * 60;
    return total / 100.0;
}

int main()
{
    int N;
    map<string, Customer> C;        // map 存储名字自动排序
    for(int i=0;i<24;i++){
        cin>>rate[i];
        rate[24] += rate[i];
    }
    cin>>N;
    string name,time,state;
    for(int i=0;i<N;i++){
        cin>>name>>time>>state;
        if(C.find(name) != C.end()){
            C[name].time.insert(pair<string,string>(time,state));
        }
        else{
            Customer temp;
            temp.name = name;
            temp.month = time.substr(0,2);
            temp.time.insert(pair<string,string>(time,state));
            C.insert(pair<string,Customer>(name,temp));
        }
    }
    
    map<string, Customer>::iterator it;
    for(it = C.begin();it != C.end();it++){
        double total = 0;
        int flag = 0;       
        //关于题目中说一定保证有一对记录会配对指的是所有记录中至少有一个配对,而并不是指每一个客户都会有一对记录会配对。
        //因此输出前应该先判断时候有配对,否则不用输出任何东西。
        //如果不考虑这个第二,三个测试点会过不了。
        Customer temp = it->second;
        set<pair<string,string> >::iterator p = temp.time.begin();
        for(; p != temp.time.end();p++){
            pair<string,string> t1 = *p;
            p++;
            if(p == temp.time.end())
                break;
            pair<string,string> t2 = *p;
            while(t1.second != "on-line" || t2.second != "off-line"){
                t1 = *p; p++;
                if(p == temp.time.end())
                    break;
                t2 = *p;
            }
            if(p == temp.time.end())
                break;
            flag++;
            if(flag == 1)
                cout<<temp.name<<" "<<temp.month<<endl;

            if(t1.second == "on-line" && t2.second == "off-line"){
                const char* on = t1.first.substr(3,8).c_str();
                const char* off = t2.first.substr(3,8).c_str();
                cout<<on<<" "<<off<<" ";
                int d1,d2,h1,h2,m1,m2;
                int minute = 0;
                double bill = 0;
                sscanf(on,"%d:%d:%d", &d1,&h1,&m1);
                sscanf(off,"%d:%d:%d", &d2,&h2,&m2);
                minute = (d2-d1)*60*24 + (h2-h1)*60 + (m2-m1);
                bill = billFromZero(d2,h2,m2) - billFromZero(d1,h1,m1);
                cout<<minute<<" ";
                cout<<fixed<<setprecision(2)<<"$"<<bill;
                cout<<endl;
                total += bill;
            }
        }
        if(flag > 0)
            cout<<"Total amount: $"<<total<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值