IMMEDIATE DECODABILITY
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13123 Accepted: 6275
Description
An encoding ofasetof symbols is said to be immediately decodable if no code forone symbol is the prefix ofa code for another symbol. We will assume for this problem that all codes are in binary, that no two codes withinasetof codes are the same, that each code has at least one bit and no more than ten bits, and that eachset has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from standard input. Each record ina group containsa collection of zeroes and ones representing a binary code fora different symbol. Each group is followed bya single separator record containing a single 9; the separator records are not part ofthe group. Each group is independent of other groups; the codes inone group are not related to codes inany other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group numberand stating whether the group is, or is not, immediately decodable.
Sample Input
0110001000009011001000009
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable
裸的trie数,求几段由01组成的数字中是否存在公共前缀。
#include<iostream>#include<cstring>#include<cstdlib>#include<algorithm>#include<cctype>#include<cmath>#include<ctime>#include<string>#include<stack>#include<deque>#include<queue>#include<list>#include<set>#include<map>#include<cstdio>#include<limits.h>#define MOD 1000000007#define fir first#define sec second#define fin freopen("/home/ostreambaba/文档/input.txt", "r", stdin)#define fout freopen("/home/ostreambaba/文档/output.txt", "w", stdout)#define mes(x, m) memset(x, m, sizeof(x))#define Pii pair<int, int>#define Pll pair<ll, ll>#define INF 1e9+7#define Pi 4.0*atan(1.0)#define lowbit(x) (x&(-x))#define lson l,m,rt<<1#define rson m+1,r,rt<<1|1typedeflonglong ll;
typedefunsignedlonglong ull;
constdouble eps = 1e-12;
constint maxn = 50010;
constint maxm = 200010;
usingnamespacestd;
inlineint read(){
int x(0),f(1);
char ch=getchar();
while (ch<'0'||ch>'9') {if (ch=='-') f=-1;ch=getchar();}
while (ch>='0'&&ch<='9') x=x*10+ch-'0',ch=getchar();
return x*f;
}
struct Trie{
int tot,root,child[maxn][2];
bool flag[maxn];
void init(){
mes(child[0],0);
flag[0]=false;
root=tot=0;
}
void insert(constchar *str){
int *cur=&root;
for(constchar *p=str;*p;++p){
cur=&child[*cur][*p-'0'];
if(0==*cur){
*cur=++tot;
mes(child[tot],0);
flag[tot]=false;
}
}
flag[*cur]=true;
}
bool query(constchar *str){
int *cur=&root;
for(constchar *p=str;*p&&*cur;++p){
cur=&child[*cur][*p-'0'];
}
return (*cur&&flag[*cur]);
}
};
int main()
{
//fin;char str[20];
int k=0,t=0;
Trie tree;
tree.init();
while(~scanf("%s",str)){
if(str[0]=='9'){
for(int i=1;i<=tree.tot;++i){
if(tree.flag[i]){
if(tree.child[i][0]||tree.child[i][1]){
k=1;
break;
}
}
}
if(!k){
printf("Set %d is immediately decodable\n",++t);
}
else{
printf("Set %d is not immediately decodable\n",++t);
}
tree.init();
k=0;
}
else{
tree.insert(str);
}
}
return0;
}