poj 3624 Charm Bracelet (01背包模板)

16 篇文章 0 订阅
8 篇文章 0 订阅

题目描述:
**

Charm Bracelet

**
Time Limit: 1000MS Memory Limit: 65536K

Description
Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input
Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output
Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7

Sample Output
23

模板题
最基础的01背包,直接上代码。

#include <cstdio>
#include <cstring>
#define MAX 3410
#define MM 12885

int w[MAX];
int c[MAX];
int dp[MM];

int max(int a, int b)
{
    return a > b ? a : b;
}

int main()
{
    int N, M;
    while(~scanf("%d %d", &N, &M))
    {
        memset(dp, 0, sizeof(dp));
        for(int i = 0; i < N; i++)
        {
            scanf("%d %d", &w[i], &c[i]);
        }

        for(int i = 0; i < N; i++)
        {
            for(int j = M; j >= w[i]; j--)
            {
                dp[j] = max(dp[j - w[i]] + c[i], dp[j]);
            }
        }

        printf("%d\n", dp[M]);
    }
    return 0;
}

运行结果:
这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值