hdu 5748 Bellovin (最长递增子序列 二分查找)

21 篇文章 0 订阅
3 篇文章 0 订阅

题目链接:hdu 5748

Bellovin

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Problem Description
Peter has a sequence a1,a2,…,an and he define a function on the sequence – F(a1,a2,…,an)=(f1,f2,…,fn), where fi is the length of the longest increasing subsequence ending with ai.

Peter would like to find another sequence b1,b2,…,bn in such a manner that F(a1,a2,…,an) equals to F(b1,b2,…,bn). Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,…,an is lexicographically smaller than sequence b1,b2,…,bn, if there is such number i from 1 to n, that ak = bk for 1 ≤ k < i and ai < bi.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤100000) – the length of the sequence. The second line contains n integers a1,a2,…,an (1≤ai≤109).

Output
For each test case, output n integers b1,b2,…,bn (1≤bi≤109) denoting the lexicographically smallest sequence.

Sample Input
3
1
10
5
5 4 3 2 1
3
1 3 5

Sample Output
1
1 1 1 1 1
1 2 3

题面要求最小字典序,其实就是求最长递增子序列的长度,所求即为f1,f2,f3…。

直接敲dp的时间复杂度是n ^ 2,会T掉,因此考虑时间复杂度为nlogn的二分写法。

#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#define MAX 100005
#define INF -0x7f7f7f7f

using namespace std;

int ans[MAX];
int arr[MAX];
int tmp[MAX];
int R = 0;

int middle(int i)//二分
{
    int l = 1, r = R, mid;
    if(arr[i] > tmp[r])
    {
        tmp[++R] = arr[i];
        return R;
    }
    else if(arr[i] <= tmp[1])
    {
        tmp[1] = arr[i];
        return 1;
    }
    while(l < r)
    {
        mid = (l + r) / 2;
        if(arr[i] > tmp[mid])
            l = mid + 1;//这里不加1可能会陷入无限循环中。
        else if(arr[i] < tmp[mid])
            r = mid;
        else
            return mid;
    }
    tmp[r] = arr[i];
    return r;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        R = 0;
        tmp[R] = 0;
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)  scanf("%d", &arr[i]);

        for(int i = 0; i < n; i++)
        {
            ans[i] = middle(i);
        }

        for(int i = 0; i < n; i++)
            if(i < n - 1)
                printf("%d ", ans[i]);
            else
                printf("%d\n", ans[i]);
    }
    return 0;
}

运行结果:
这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值