codeup22039 TIME

codeup22039  TIME

时空限制    1000ms/128MB

题目描述

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

输入

There are several test cases.

Each case contains 4 integers in a line, separated by space.

Proceed to the end of file.

输出

For each test case, output the time expressed by the digital clock such as Sample Output.

样例输入

1 2 5 6
2 3 4 2

样例输出

    _  _  _
  | _||_ |_
  ||_  _||_|
 _  _     _
 _| _||_| _|
|_  _|  ||_

提示

The digits showed by the digital clock are as follows:

   _  _     _  _  _  _  _  _

 | _| _||_||_ |_   ||_||_|| |

 ||_  _|  | _||_|  ||_| _||_|

 

代码

法一:字符数组

#include<iostream>
using namespace std;
const char s[10][3][3] = {{{' ','_',' '},{'|',' ','|'},{'|','_','|'}},
						  {{' ',' ',' '},{' ',' ','|'},{' ',' ','|'}},
						  {{' ','_',' '},{' ','_','|'},{'|','_',' '}},
						  {{' ','_',' '},{' ','_','|'},{' ','_','|'}},
						  {{' ',' ',' '},{'|','_','|'},{' ',' ','|'}},
						  {{' ','_',' '},{'|','_',' '},{' ','_','|'}},
						  {{' ','_',' '},{'|','_',' '},{'|','_','|'}},
						  {{' ','_',' '},{' ',' ','|'},{' ',' ','|'}},
						  {{' ','_',' '},{'|','_','|'},{'|','_','|'}},
						  {{' ','_',' '},{'|','_','|'},{' ','_','|'}}};

int main(){
	int a[4];
	while (cin>>a[0]>>a[1]>>a[2]>>a[3]){
		for (int i=0; i<3; i++){
			for (int j=0; j<4; j++)
				for (int k=0; k<3; k++) cout<<s[a[j]][i][k];
			cout<<endl;
		}
	}
	return 0;
}

法二:字符串

#include<iostream>
#include<string>
using namespace std;
string  top[10]={" _ ","   "," _ "," _ ","   "," _ "," _ "," _ "," _ "," _ "},
		mid[10]={"| |","  |"," _|"," _|","|_|","|_ ","|_ ","  |","|_|","|_|"},
		bot[10]={"|_|","  |","|_ "," _|","  |"," _|","|_|","  |","|_|"," _|"};

int main(){
	int a,b,c,d;
	while (cin>>a>>b>>c>>d){
		cout<<top[a]<<top[b]<<top[c]<<top[d]<<endl;
		cout<<mid[a]<<mid[b]<<mid[c]<<mid[d]<<endl;
		cout<<bot[a]<<bot[b]<<bot[c]<<bot[d]<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值