ybt1169 大整数减法(高-高)

ybt1169  大整数减法

时空限制    1000ms/64M

题目描述

        求两个大的正整数相减的差。

输入

        共2行,第1行是被减数a,第2行是减数b(a > b)。每个大整数不超过200位,不会有多余的前导零。

输出

        一行,即所求的差。

输入样例

9999999999999999999999999999999999999
9999999999999

输出样例

9999999999999999999999990000000000000

代码

法一:数组模拟

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
const int N = 205;
int a[N],b[N],c[N];

void zhuan(string s,int a[]){
	memset(a,0,sizeof(int)*N);
	a[0] = s.size();
	for (int i=1; i<=a[0]; ++i) a[i]=s[a[0]-i]-48;
}

void sub(int a[],int b[],int c[]){
	memset(c,0,sizeof(int)*N);
	c[0] = a[0];
	for (int i=1; i<=c[0]; ++i){
		if (a[i]<b[i]) a[i+1]--,a[i]+=10;
		c[i] = a[i]-b[i];
	}
	while (c[c[0]]==0 && c[0]>1) --c[0];
}

void output(int a[]){
	for (int i=a[0]; i>=1; --i) cout<<a[i];
	cout<<'\n';
}

int main(){
	string s1,s2;
	while (cin>>s1>>s2){
		zhuan(s1,a); zhuan(s2,b);
		sub(a,b,c);
		output(c);
	}
	return 0;
}

法二:重载运算符

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
const int N = 205;
struct bign{
	int len,d[N];
	bign(){ memset(d,0,sizeof(d)); len=1; }	//构造函数,默认初始化
	bign(string x){							//构造函数,string初始化
		memset(d,0,sizeof(d));
		len = x.size();
		for (int i=1; i<=len; ++i) d[i]=x[len-i]-48;
	}
	void clear0(){	//成员函数  清掉高位0,保证至少1位
		while (d[len]==0 && len>1) --len;
	}
	bign operator - (const bign &b){		//重载- 高-高
		bign c;		//c=结构体本身-b
		c.len = len;
		for (int i=1; i<=len; ++i){
			if (d[i]<b.d[i]) d[i+1]--,d[i]+=10;
			c.d[i] = d[i]-b.d[i];
		}
		c.clear0();
		return c;
	}
	friend istream& operator >> (istream& input,bign &x){	//重载输入流
		string s;
		input>>s;
		x = s;
		return input;
	}
	friend ostream& operator << (ostream& output,const bign &x){//重载输出流
		for (int i=x.len; i>=1; --i) cout<<x.d[i];
		return output;
	}
};

int main(){
	bign a,b;
	while (cin>>a>>b)		//需重载输入流
		cout<<a-b<<'\n';	//需重载输出流、高-高
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值