poj1328 Radar Installation

poj1328  Radar Installation

时空限制    1000ms/10000K

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


分析


假如有一个岛屿在A点,那么以点A为圆心,d为半径画圆,如果和海岸线有交集,就是图中红色部分(红色部分为可以安装雷达装置的地方),可以求出B,C点坐标,即把点转换为区间。

由贪心的原则,把装置安装在C点最优。

输入数据时,转化为区间,后把区间以右边按升序排序

初始化数据ans=1,s=a[1].y


代码

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
struct node{
	double x,y;
	bool operator < (const node &X)const{
		return x<X.x;
	}
};
node a[1005];

int main(){
	int n,d,num=0;
	while (cin>>n>>d){
		if (n==0 && d==0) break;
		int ans=1;
		for (int i=1,x,y; i<=n; i++){
			cin>>x>>y;
			if (y>d) ans=-1;
			double t=sqrt(1.0*d*d-y*y);
			a[i].x=x-t;
			a[i].y=x+t;
		}
		if (ans!=-1){
			sort(a+1,a+n+1);
			double s=a[1].y;
			for (int i=2; i<=n; i++)
				if (a[i].x>s) ans++,s=a[i].y;
				else if (a[i].y<s) s=a[i].y;
		}
		cout<<"Case "<<++num<<": "<<ans<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值