poj 1990 MooFest (两个树状数组)

MooFest
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4582 Accepted: 1913

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows.

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57
 
参考题解http://blog.sina.com.cn/s/blog_6635898a0100q0lk.html
 
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <cmath>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll __int64
#define eps 1e-6

using namespace std;

const int INF = 1000000000;
const int maxn = 20005;
struct node
{
    int v,x;
}cow[maxn];
int n;
bool cmp(node a, node b)
{
    return a.x < b.x;
}
int lowbit(int x)
{
    return x & (- x);
}
void add(int x, int d, ll *a)
{
    for(int i = x; i < maxn; i += lowbit(i))
    a[i] += d;
}
ll sum(int x, ll *a)
{
    int ret = 0;
    for(int i = x; i > 0; i -= lowbit(i))
    ret += a[i];
    return ret;
}
int main()
{
    ll num[maxn], dis[maxn];
    while(~scanf("%d", &n))
    {
        for(int i = 0; i < n; i++)
        scanf("%d%d", &cow[i].v, &cow[i].x);
        sort(cow, cow + n, cmp);

        memset(num, 0, sizeof(num));
        memset(dis, 0, sizeof(dis));

        ll ans = 0;

        for(int i = 0; i < n; i++)
        {
            ans += (sum(cow[i].v - 1, num) * cow[i].x-sum(cow[i].v - 1, dis)) * cow[i].v;
            add(cow[i].v, 1, num);
            add(cow[i].v, cow[i].x, dis);
        }

        memset(num, 0, sizeof(num));
        memset(dis, 0, sizeof(dis));

        for(int i = n - 1; i >= 0; i--)
        {
            ans += (sum(cow[i].v, dis) - sum(cow[i].v, num) * cow[i].x) * cow[i].v;
            add(cow[i].v, 1, num);
            add(cow[i].v, cow[i].x, dis);
        }

        printf("%I64d\n", ans);
    }

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值