poj 1837 Balance

52 篇文章 0 订阅
18 篇文章 0 订阅
Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8724 Accepted: 5299

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2
 
题意:有一个天平,有c个钩码,g个砝码。给出c个钩码相对与0点的位置,和g个砝码的质量。求把所有砝码放上天平,使得天平平衡的方法数。
思路:力矩=力臂*质量。当两边力矩差为0时,则天平平衡。因为题目保证存在平衡的状况,则两边的力矩都不会超过20*15*25/2=3750。
 
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;
int dp[25][7505];  //dp[i][j]挂i个砝码,力矩差为j的方法数
int w[25],x[25];
int main()
{
   int c,g;
   scanf("%d%d",&c,&g);
   for(int i=0;i<c;i++)
   scanf("%d",&x[i]);
   for(int i=0;i<g;i++)
   scanf("%d",&w[i]);
   memset(dp,0,sizeof(dp));
   for(int i=0;i<c;i++)      //两边要平衡,那么两边的力矩都不会超过3750,因为存在负值,所以+3750
   dp[1][x[i]*w[0]+3750]=1;
   for(int i=1;i<g;i++)
   for(int j=0;j<c;j++)
   for(int k=0;k<=7500;k++)
   if(dp[i][k])            //表示能达到放入i个砝码,力矩差为k的状态
   dp[i+1][k+w[i]*x[j]]+=dp[i][k];     //砝码能放在c个地方,所以要全部加上

   cout<<dp[g][3750]<<endl;
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值