poj 1837 Balance -dp-01背包

Balance

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2



题意

题意:一个天平上有C个挂钩,第i个挂钩的位置为C[i],C[i] < 0表示该挂钩在原点的左边,C[i] > 0表示该挂钩在原点的右边;然后给出G个钩码的重量,问有多少种挂法使得天平保持平衡,要求砝码要都用上。


解题思路

天平平衡条件 : 左右力臂差为0。即左臂长*重量=右臂长*重量

可得力臂差的范围是 -7500~7500

当力臂差=0时,平衡,<0天平左倾,>0天平右倾。

当天平平衡时,每向天平上挂一个钩码,天平的状态就会改变,而这个状态可以由若干前一状态获得。

用dp【i】【j】表示使用i个砝码,使得力臂差为j时的方案数。

由于j不能为负数。所以给他加上一个相对高度h,使得j不为负数,由于力臂差的范围是 -7500~7500,所以h=7500,这样修改后,力臂差范围是0~15000

当力臂差为7500时平衡。

这里不能使用一维数组因为达到力臂差【j】的方案有很多种,但是不都满足每个砝码都用上。所以必须加上用了几个砝码这一维



代码

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int c,g;
int l[20],w[20];
int dp[20][15000];
int main()
{
    scanf("%d%d",&c,&g);
    for(int i=1;i<=c;++i){//从1开始
        scanf("%d",&l[i]);
    }
    for(int i=1;i<=g;++i){
        scanf("%d",&w[i]);
    }
    memset(dp,0,sizeof(dp));
    dp[0][7500] = 1;//使用0个砝码,使力臂差为7500(为0)的方案有一个
    for(int i=1;i<=g;++i)
    {
        for(int j=15000;j>=0;--j)//因为是二维的所以j的枚举顺序无所谓
        {
            if(dp[i-1][j])//这种情况下有方案数
            {
                for(int k=1;k<=c;++k)
                    dp[i][j+l[k]*w[i]]+=dp[i-1][j];//打达到力臂差=(j+l[i]*w[i])的方式可能有很多种,所以要加上从dp[i-1][j]这种方式得到的方案
            }
        }
    }
    printf("%d",dp[g][7500]);
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值