poj 1201 Intervals(差分约束求最长路)

Intervals
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19189 Accepted: 7216

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6
 
题意:给出n个区间,每个区间给出一个数ci,求一个size最小的整数集合,使该集合落在每个区间的元素>=ci。
思路:设为区间[0,i]有sum[i]个数,则对于每个关系a,b,c,有sum[b+1]-sum[a]>=c。另外隐藏条件为0<=sum[i+1]-sum[i]<=1。要求最小值,则求最长路,对于(b+1)-a>=c,建一条边为a->b+1,边权为c。
 
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <map>


using namespace std;

const int INF=100000000;
const int maxn=50005;

struct node
{
    int v,w,next;
} edge[maxn*3];
int head[maxn],dis[maxn];
bool vis[maxn];
int num,n,m,maxi,mini;
void init()
{
    memset(head,-1,sizeof(head));
    num=0;
}
void add(int u,int v,int w)
{
    edge[num].v=v;
    edge[num].w=w;
    edge[num].next=head[u];
    head[u]=num++;
}
int spfa()
{
    queue<int>Q;
    for(int i=mini; i<=maxi; i++)
        dis[i]=-INF;
    dis[mini]=0;
    memset(vis,false,sizeof(vis));
    vis[mini]=true;
    Q.push(mini);
    while(!Q.empty())
    {
        int x=Q.front();
        Q.pop();
        vis[x]=false;
        for(int i=head[x]; i!=-1; i=edge[i].next)
        {
            if(dis[edge[i].v]<dis[x]+edge[i].w)
            {
                dis[edge[i].v]=dis[x]+edge[i].w;
                if(!vis[edge[i].v])
                {
                    vis[edge[i].v]=true;
                    Q.push(edge[i].v);
                }
            }
        }
    }
    return dis[maxi];
}
int main()
{
    int a,b,c;
    while(scanf("%d",&n)!=EOF)
    {
        init();
        maxi=0;        
        mini=INF;
        while(n--)
        {
            scanf("%d%d%d",&a,&b,&c);
            maxi=max(maxi,b+1);
            mini=min(mini,a);
            add(a,b+1,c);
        }
        for(int i=mini;i<maxi;i++)
        {
            add(i,i+1,0);
            add(i+1,i,-1);
        }
        printf("%d\n",spfa());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值