POJ 1852

<span style="font-size: 18pt; font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">Ants</span>
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10461 Accepted: 4631

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207
 
本题要求的是蚂蚁全部落下杆的最短时间和最长时间,则需要求所有蚂蚁落下杆的最短时间中最短的那个,min_t = min(min_t,time(i))以及所有蚂蚁落下杆的最长时间中最长的那个,max_t = max(max_t,time(i)).依据是每只蚂蚁相互碰撞时,都朝相反的方向去继续行走,这相当于每只蚂蚁依旧前行,因此不必考虑蚂蚁行走的细节,只需要将每只蚂蚁行走的最短和最长时间即可。
这里还需要注意的一点是,假设杆长为10cm,离杆左端2cm的蚂蚁,最短时间为2秒,最长时间为8秒。我就是因为这个细节WA了两次,以为最短时间是1秒。
#include <iostream>
#include <string.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <stack>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <cstdlib>
#include <cmath>
#include <math.h>
#include <vector>
#include <map>
#include <time.h>
#include <ctime>
using namespace std;
#define M 1000005
int f[M];
int main()
{
    int t;
    int n, m;
    int sbig, small, big;
    scanf("%d",&t);
    for(int i = 0; i < t; i++)
    {
        scanf("%d%d",&n,&m);
        memset(f,0,sizeof(f));
        big = 0;
        small = M;
        sbig = 0;
        for(int j = 0; j < m; j++)
        {
            scanf("%d",&f[j]);
        }
        sort(f,f+m);
        int num1, num2;
        for(int j = 0; j < m; j++)
        {
            num1 = f[j];
            num2 = n - f[j];
            if(num1 < num2)
                swap(num1,num2);
            if(num1 > big)
                big = num1;
            if(num2 > sbig)
                sbig = num2;
        }
        printf("%d %d\n",sbig,big);
    }
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值