HDU 2084 数塔

数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24668    Accepted Submission(s): 14840


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input
  
  
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
 

Sample Output
  
  
30
方法一:DP
从倒数第二行往上开始DP,对每一行的元素进行更新,更新的方法:对于元素f[x][y],f[x][y] += max(f[x+1][y],f[x+1][y+1]);即保证从下往上每一条路径上的最大值都求出来,当x == 1&& y == 1时,输出f[1][1],就求出最大和。
代码:
#include <iostream>
#include <string.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <stack>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <cstdlib>
#include <cmath>
#include <math.h>
#include <vector>
#include <map>
#include <time.h>
#include <ctime>
using namespace std;
#define M 105
int f[M][M];
int main()
{
    int t, n;
    cin >> t;
    for(int k = 0; k < t; k++)
    {
        cin >> n;
        memset(f,0,sizeof(f));
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= i; j++)
            {
                scanf("%d",&f[i][j]);
            }
        }
        for(int i = n-1; i >= 1; i--)
        {
            for(int j = 1; j <= i; j++)
            {
                f[i][j] += max(f[i+1][j],f[i+1][j+1]);
            }
        }
        printf("%d\n",f[1][1]);
    }
    return 0;
}

方法二:递归求解
与DP类似,将DP的递推求解转化为递归式,需要注意的是,递归求解会出现重复路径,增加时间复杂度,因此需要进行优化,重复的路径不需要再进行递归,直接返回值。

代码:
#include <iostream>
#include <string.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <stack>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <cstdlib>
#include <cmath>
#include <math.h>
#include <vector>
#include <time.h>
#include <ctime>
using namespace std;
#define M 105
int num[M][M];
int dp[M][M];
int t, n;
int DFS(int x, int y);
int main()
{
    cin >> t;
    for(int k = 0; k < t; k++)
    {
        cin >> n;
        memset(num,0,sizeof(num));
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= i; j++)
                scanf("%d",&num[i][j]);
        memset(dp,-1,sizeof(dp));
        int ans = DFS(1,1);
        printf("%d\n",ans);
    }
    return 0;
}
int DFS(int x, int y)
{   
    if(x == n || y == n)        //当找到最后一行时,返回
        return num[x][y];
    if(dp[x][y] != -1)          //避免重复的查找
        return dp[x][y];
    return dp[x][y] = max(DFS(x+1,y+1),DFS(x+1,y)) + num[x][y];     //更新dp数组
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值