【杭电 1061】 Rightmost Digit

Rightmost Digit

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

主要掌握模幂运算,而且求个位,一直求10的模
这个是大数问题吧,不过数据太大一定有技巧的,n^n(n<=1000000000), 题目要取的是个位数字,所以我们只有把(n)^n就可以了,因为进位对个位不影响,对于n的次方还是很大,我们就先求n/2,可是还是要考虑到n为奇数的时候 t=t*t*a,(a=n);比如当n=5的时候n/2=2,t=(a^2)(a^2)(a)=a^5,但a^4即n=4;n/2=2;此时t=(a^2)*(a^2)

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int node(__int64 m)
{
    int t=1,b;
    b=m%10;
    if(b==0)
    return 0;
    while(m)
    {
        if(m%2==1)
        {
        t*=b;
        t%=10;  
        }
        b*=b;
        b%=10;
        m/=2;
    }
    return t;
}
int main()
{
    int t;
    __int64 n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        printf("%d\n",node(n));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值