【杭电 5053】the Sum of Cube

14 篇文章 0 订阅

the Sum of Cube

Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.

Sample Input
2
1 3
2 5

Sample Output
Case #1: 36
Case #2: 224

求区间内所有数的立方~~~代码如下:

#include<stdio.h>
__int64 su(__int64 a,__int64 b)
{
    __int64 i;
    __int64 sum=0;
    for(i=a;i<=b;i++)
    sum+=i*i*i;
    return sum;
} 
int main()
{
    int t,l=1;
    scanf("%d",&t);
    while(t--)
    {
        __int64 m,n;
        scanf("%I64d%I64d",&n,&m);
        printf("Case #%d: %I64d\n",l++,su(n,m));
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值