(一):the Sum of Cube(立方和。。。。高效率)

Description

A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.
 

Input

The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve. 
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].
 

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.
 

Sample Input

    
    
2 1 3 2 5
 

Sample Output

    
    
Case #1: 36 Case #2: 224
  看表格求立方和

4444444444
4444444444
4444444444
4444444444
3333334444
3333334444
3333334444
2223334444
2223334444
1223334444
        看表后,很容易看出来求1到4的立方和就是求这个(单元格边长为1)正方形表格的面积;;;(假设求从1到n的之间的数的立方和)则表格边长为n*(n+1)/2...代码如下:
#include<stdio.h>
int main()
{
	int t;
	double m,n,sum;
	double s1,s2;
	int cont=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf %lf",&m,&n);     //the range[m,n]
		s1=(m*(m-1)/2)*(m*(m-1)/2);   //从1到m-1的数的立方和 
		s2=(n*(n+1)/2)*(n*(n+1)/2);   //从1到n的数的立方和 
		sum=s2-s1;					//从m到n的数的立方和
		printf("Case #%d: %.lf\n",++cont,sum); 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值