【UVA 548 Tree】二叉树构造 & 遍历

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a
path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values
of nodes along that path.
Input
The input file will contain a description of the binary tree given as the inorder and postorder traversal
sequences of that tree. Your program will read two line (until end of file) from the input file. The first
line will contain the sequence of values associated with an inorder traversal of the tree and the second
line will contain the sequence of values associated with a postorder traversal of the tree. All values
will be different, greater than zero and less than 10000. You may assume that no binary tree will have
more than 10000 nodes or less than 1 node.
Output
For each tree description you should output the value of the leaf node of a path of least value. In the
case of multiple paths of least value you should pick the one with the least value on the terminal node.
Sample Input
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255
Sample Output
1
3
255

题意: 根据中序遍历和后序遍历构造二叉树,并输出从根遍历权值最小的轮径的叶子节点,权值相同的情况下,输出叶子节点最小的那个

思路 : 构造 & 遍历

AC代码:

#include<cstdio>
#include<cmath>
#include<deque>
#include<queue>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e5 + 10;
const int INF = 1e9 + 7;
typedef long long LL;
int l[MAX],r[MAX],h[MAX],z[MAX],nl,ans,sum;
char c;
bool readz(){
    char c;
    nl = 1;
    if(scanf("%d",&z[1]) == -1) return 0;
    while(scanf("%c",&c) && c == ' ')
        scanf("%d",&z[++nl]);
    return 1;
}
void readh(){
    for(int i = 1; i <= nl; i++)
        scanf("%d",&h[i]);
}
int gz(int l1,int r1,int l2,int r2){
    if(l1 > r1) return 0;
    int t = h[r2];
    int n = l1;
    while(z[n] != t) n++;
    int nn = n - l1;
    l[t] = gz(l1,n - 1,l2,l2 + nn - 1);
    r[t] = gz(n + 1,r1,l2 + nn,r2 - 1);
    return t;
}
void sc(int o,int vl){
    vl += o;
    if(!l[o] && !r[o]){
        if(vl < ans || (vl == ans && o < sum)){
            ans = vl;
            sum = o;
            return ;
        }
    }
    if(l[o]) sc(l[o],vl);
    if(r[o]) sc(r[o],vl);
}
int main()
{
    while(readz()){
        readh();
        memset(l,0,sizeof l);
        memset(r,0,sizeof r);
        gz(1,nl,1,nl);
        ans = sum = INF;
        sc(h[nl],0);
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值