UVA-548 Trees

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input
The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output
For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255 255

Sample Output
1
3
255

分析:用递归的方式构建树,后序遍历的最后一个数是根结点,在中序遍历中找到根,将树分成左右两个子树。然后在两个子树中重复以上过程。具体看代码。

Source:

#include<iostream>
#include<string>
#include<sstream>
#include<algorithm>
using namespace std;

const int MAXN=10000+10;
int in_order[MAXN],post_order[MAXN];
int lch[MAXN],rch[MAXN];       //保存左右子树的根结点
int n,best,best_sum;

bool read_list(int *a)
{
    string line;
    if(!getline(cin,line))
        return false;
    stringstream ss(line);
    n=0;
    int x;
    while(ss>>x)
        a[n++]=x;
    return n>0;
}

int build(int L1,int R1,int L2,int R2)
{
    if(L1>R1)      //空树
        return 0;
    int root=post_order[R2];    //后序遍历的最后一个是根结点
    int p=L1;
    while(in_order[p]!=root)    //在中序遍历中寻找根结点
        p++;
    int cnt=p-L1;          //左子树的结点个数
    lch[root]=build(L1,p-1,L2,L2+cnt-1);   //递归求左右子树的子树
    rch[root]=build(p+1,R1,L2+cnt,R2-1);
    return root;          //返回根结点
}

void dfs(int u,int sum)    //遍历树,寻找最优解
{
    sum+=u;
    if(!lch[u]&&!rch[u])
    {
        if(sum<best_sum||(sum==best_sum&&u<best))
        {
            best=u;
            best_sum=sum;
        }
    }
    if(lch[u])
        dfs(lch[u],sum);
    if(rch[u])
        dfs(rch[u],sum);
}

int main()
{
    while(read_list(in_order))
    {
        read_list(post_order);
        build(0,n-1,0,n-1);
        best_sum=1000000000;
        dfs(post_order[n-1],0);
        cout<<best<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值